Mobile Login Issue: Session Expired
Incident Report for Inspectorio INC
Resolved
The issue has been resolved and verified.

The incident has been identified as a configuration issue occurred from CloudFlare side. We have updated our own configuration to resolve the issue, and is currently working on developing a long term fix.

We thank you for your patience in bearing with us. If there are further questions and/or requests about this incident, please feel free to reach out to our Support Team at Support@Inspectorio.com.
Posted Nov 15, 2022 - 07:10 UTC
Monitoring
The fix has been applied on production environment. We are monitoring the issue and perform a fix verification. Next update in 15 minutes - at 2.15pm GMT+7.

Thank you for your patience and for bearing with us.
Posted Nov 15, 2022 - 07:03 UTC
Identified
The root cause has been identified.

We have identified the issue with the configuration in Cloudflare firewall that prevents some of the requests to reach through to us, which caused the incident.
Preventive: SEC will review the current firewall rules to prevent it from happening again.

Our Engineering team has already started to work on a fix and we'll share another update soon.
Posted Nov 15, 2022 - 06:56 UTC
Update
We are still investigating the issue.
Impact scope: Android users will experience disruptions of service when they attempt to upload reports due to a session timeout issue. There is no identified cases with iOS users as of this moment.
Our internal user was able to replicate the issue on Android, and we are taking a deeper look into the logs.
Next update will be at 2:00pm GMT+7`
Posted Nov 15, 2022 - 06:49 UTC
Update
Currently all the affected users are reporting problems from their Android devices, no report coming from iOS so far. Internal users are attempting to replicate the issue, not yet reproducible. We will post another update as soon as we learn more.
Posted Nov 15, 2022 - 06:36 UTC
Investigating
Our Engineering team is investigating an issue with Sight Mobile App. At this time, users may experience trouble logging in and some Android users reported that they are experiencing Session Expired issues. We apologize for the inconvenience. We will share an update once we have more information.
Posted Nov 15, 2022 - 06:26 UTC
This incident affected: Sight (Mobile API).